Installed but looking for


It has been a while since I have been on this site as fenics has been working great for me. I installed fenics on a new cluster recently with no problem. But I needed to write detailed instructions on how to do this and when I tried to reproduce the same result I now get an error. I have the newest versions of anaconda and conda installed currently. Below are what I did to install fenics:

$ conda create -n fenicsproject -c conda-forge Fenics

(base) [tpm92@tds-sbc2-dl local_installs]$ conda create -n fenicsproject -c conda-forge Fenics
Collecting package metadata (current_repodata.json): done
Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): done
Solving environment: done
Preparing transaction: done
Verifying transaction: done
Executing transaction: done
# To activate this environment, use
#     $ conda activate fenicsproject
# To deactivate an active environment, use
#     $ conda deactivate

(base) $ conda activate fenicsproject
(fenicsproject) $

but when I try to run a script with

from fenics import *


from dolfin import *

I get the following error:

$ python
Traceback (most recent call last):
  File "/data/work/tpm92/Layers_10_11/test_timing/submit_scripts/", line 2, in <module>
    from fenics import *
  File "/home/tpm92/work/data/local_installs/anaconda3/envs/fenicsproject/lib/python3.9/site-packages/fenics/", line 7, in <module>
    from dolfin import *
  File "/home/tpm92/work/data/local_installs/anaconda3/envs/fenicsproject/lib/python3.9/site-packages/dolfin/", line 34, in <module>
    from .cpp import __version__
ImportError: cannot open shared object file: No such file or directory

It appears fenics intit is looking for when has been installed in local_installs/anaconda3/envs/fenicsproject/lib/ Can anyone suggest a simple fix to this? Any help would be greatly appreciated!

All the best,

I have encounter the same issue

1 Like

easy fix: Activate fenics enviroment and downgrade to superlu6 with conda

conda activate fenicsproject
conda install -c conda-forge superlu_dist=6.2.0

runs fine now!


I have the same issue