Invalid MIT-MAGIC-COOKIE-1 key

Hello!

I am using ‘FEniCS 2019.1.0.post0’ on Ubuntu 20.04, and when I perform ‘import dolfin’ it shows ‘Invalid MIT-MAGIC-COOKIE-1 key’.

Anything to be concerned? Any recommendations?

Thank you!
Meen

See for instance https://unix.stackexchange.com/questions/199891/invalid-mit-magic-cookie-1-key-when-trying-to-run-program-remotely
or
https://askubuntu.com/questions/1238389/invalid-mit-magic-cookie-1-key-message-while-running-a-program-with-the-termin

This problem plagued me on a previous machine. None of the suggestions on the discussion sites fixed it. Never did resolve it. Got an new computer and the problem isn’t showing on the new installation.

This magic-cookie warning is “mostly harmless”, it should be safe to ignore it. If the suggestions in Dokken’s links don’t help, and the warning continues being a problem, then a clean reinstallation will probably fix it.

1 Like

Thank you very much for your kind reply. Do you mean clean installation of FEniCS or OS itself?

Have a great day!
M

Thank you very much for your help!

The OS. This problem has nothing to do with FEniCS.

Thank you very much. Hopefully I could fix it.

Hi Tkadeethum,
I’m experimenting the same trouble. Could you tell us how you fixed it ?
Thanks in advance

Hi,

I hope @tkadeethum solved this, so that can help you.

However, I’ve spent a lot of time trying to fix this warning, I checked many posts on the web about it, but I still have it.

Nevertheless, it hasn’t caused me any troubles with FEniCS, as @dparsons already pointed out. So my advice is to live peacefully with the Invalid MIT-MAGIC-COOKIE-1 key message without caring too much about it.

Thanks @CastriMik for your answer ! I totally agree with you :slight_smile: