Trouble with installing Spyder for FEniCS through Anaconda

I’m totally new to both Anaconda and FEniCS. I realize my question might be trivial, and I’ve tried to find a solution on google and here, but without results. My problem arose when trying to find a suitable editor to write in when using Anaconda and FEniCS.

So, I installed FEniCS through Anaconda through conda-forge using the following code line

conda create -n fenicsproject -c conda-forge fenics

source activate fenicsproject

In this environment, I thought I wanted to install spyder to use as editor. However, when I type

conda install spyder

in the FEniCS enabled terminal, I receive the following error:

Finding shortest conflict path fo- python-jsonrpc-server[version='>=0.3.2']:  failed                                                                                                                                                          
UnsatisfiableError: The following specifications were found 
to be incompatible with the existing python installation in your environment:


  - spyder -> python[version='<3.4']

Your python: python=3.8

If python is on the left-most side of the chain, that's the version you've asked for.
When python appears to the right, that indicates that the thing on the left is somehow
not available for the python version you are constrained to. Note that conda will not
change your python version to a different minor version unless you explicitly specify

The following specifications were found to be incompatible with each other:

Package pip conflicts for:
python=3.8 -> pip
spyder -> python[version='>=2.7,<2.8.0a0'] -> pip
Package setuptools conflicts for:
python=3.8 -> pip -> setuptools
spyder -> pygments[version='>=2.0'] -> setuptools
spyder -> python-language-server[version='>=0.31.2,<0.32.0'] -> flake8 -> setuptools[version='>=30.0.0']
Package certifi conflicts for:
python=3.8 -> pip -> setuptools -> certifi[version='>=2016.09|>=2016.9.26']
spyder -> pygments[version='>=2.0'] -> setuptools -> certifi[version='>=2016.09|>=2016.9.26|>=2017.4.17']
Package ca-certificates conflicts for:
python=3.8 -> openssl[version='>=1.1.1d,<1.1.2a'] -> ca-certificates
spyder -> python[version='>=2.7,<2.8.0a0'] -> ca-certificates
Package wheel conflicts for:
spyder -> python[version='>=2.7,<2.8.0a0'] -> pip -> wheel
python=3.8 -> pip -> wheel
Package python-language-server conflicts for:
spyder -> python-language-server[version='>=0.31.2,<0.32.0']
Package ipython_genutils conflicts for:
spyder -> applaunchservices -> ipython_genutils
Package ipython conflicts for:
spyder -> qtconsole[version='>=4.6.0'] -> ipykernel[version='>=4.1'] -> ipython[version='>=4.0|>=4.0.0|>=5.0']

I also tried to install the Anaconda package which includes spyder, however the installation just froze. Jupyter Notebook does not work either…

I assume there might me something I’m entirely missing out here, but please could someone help me?

When you first create the environment for FEniCS, you may specify the Python version to 3.5. Then try to install the spyder. The spyder installation process may take a little longer than you think…

Sebastian @smyrback
If you are still wanting a solution on how to use Spyder with FEniCS, check out our thread here.