How to run fenics in parallel?

Hi all,

I’m trying to run my scrip in parallel with

mpirun -np 64 python3 script.py

but get the following error in the terminal:

[v-VirtualBox:02207] *** Process received signal ***
[v-VirtualBox:02207] Signal: Segmentation fault (11)
[v-VirtualBox:02207] Signal code: Address not mapped (1)
[v-VirtualBox:02207] Failing at address: 0x28
[v-VirtualBox:02207] [ 0] /lib/x86_64-linux-gnu/libpthread.so.0(+0x12890)[0x7f83d6214890]
[v-VirtualBox:02207] [ 1] /usr/lib/x86_64-linux-gnu/openmpi/lib/openmpi/mca_pmix_pmix112.so(+0x31433)[0x7f83cd366433]
[v-VirtualBox:02207] [ 2] /usr/lib/x86_64-linux-gnu/libopen-pal.so.20(opal_libevent2022_event_base_loop+0x7f1)[0x7f83d6486c31]
[v-VirtualBox:02207] [ 3] /usr/lib/x86_64-linux-gnu/openmpi/lib/openmpi/mca_pmix_pmix112.so(+0x2efcd)[0x7f83cd363fcd]
[v-VirtualBox:02207] [ 4] /lib/x86_64-linux-gnu/libpthread.so.0(+0x76db)[0x7f83d62096db]
[v-VirtualBox:02207] [ 5] /lib/x86_64-linux-gnu/libc.so.6(clone+0x3f)[0x7f83d5f3288f]
[v-VirtualBox:02207] *** End of error message ***
Segmentation fault (core dumped)

Here all the modules that I am including:

from dolfin import*
import numpy as np
import matplotlib.pyplot as plt
from matplotlib import *
from mshr import *
import os
from scipy.interpolate import interp1d
import scipy as sp

What causes the error? Is there some kind of document that helps using fenics in parallel?
Thank you!

How did you install dolfin?
Usually, dolfin scripts run out of the box in parallel (few exceptions)
Have you tried to run some of the demos in parallel?
(https://bitbucket.org/fenics-project/dolfin/src/master/python/demo/documented/)

I installed it like this:

sudo apt-get install software-properties-common

sudo add-apt-repository ppa:fenics-packages/fenics

sudo apt-get update

sudo apt-get install --no-install-recommends fenics

I haven’t tried running the simulations, thanks for the hint, will do it.